Fix Invalid Shortcuts utility issue

Discuss problems regarding Acelogix Software products and find solutions
FAM07
Posts: 114
Joined: Fri Jul 06, 2007 12:51 pm

Fix Invalid Shortcuts utility issue

Post by FAM07 » Sat Sep 29, 2012 2:20 pm

Hi,
This is a recurrent issue that I believe it is not solved yet.
I have the last version of Ace Utilities (v.5.2.5) and the Fix Invalid Shortcuts utility does not work properly for a limited user account, my case is on Windows 7 Home Premium 64 bit. Checked On in All Drivers, this utility finds a lot of shortcuts of the limited user account as erroneous when they are correct. All limited user account items showed in Shortcut Location column are related to an administrator user account files in the Target Location column when they should be related to limited user account files. For shortcuts of administrator user account the utility works fine.
I would like to know why the Fix Invalid Shortcut utility (with selected All Drives option) detects invalid shortcuts of the limited user account erroneously because the utility relates them to administrator user account files. Is it possible a solution for this issue?
Thanks in advance.

FAM07
Posts: 114
Joined: Fri Jul 06, 2007 12:51 pm

Re: Fix Invalid Shortcuts utility issue

Post by FAM07 » Sun Jan 20, 2013 4:41 pm

Attached is an image of the Fix Invalid Shortcuts results.

(Options/Fix Invalid Shortcuts: Scan All Drive (C:\) and Scan all references to removable... selected; Win 7 64bit)

See in C:\Users\Virginia (limited user account), where the Target Location appears as C:\Users\Fabio (admin user account). Why this behaviuor? Is this correct?

I will be waiting your comments, thanks.
Attachments
fix invalid shortcuts results.png
fix invalid shortcuts results.png (219.14 KiB) Viewed 12318 times

hari
Site Admin
Posts: 675
Joined: Sat Dec 13, 2003 2:15 am

Re: Fix Invalid Shortcuts utility issue

Post by hari » Sun Aug 24, 2014 2:05 am

I think we fixed this in 5.5. Please confirm.
regards,
Hari, Acelogix Team

FAM07
Posts: 114
Joined: Fri Jul 06, 2007 12:51 pm

Re: Fix Invalid Shortcuts utility issue

Post by FAM07 » Mon Aug 25, 2014 7:43 pm

Hi,
I confirm the issue en AU 5.5 (please see my post http://www.acelogix.com/forums/viewtopic.php?f=2&t=4292)

Thanks

FAM07
Posts: 114
Joined: Fri Jul 06, 2007 12:51 pm

Re: Fix Invalid Shortcuts utility issue

Post by FAM07 » Sat Aug 30, 2014 7:35 pm

MESSAGE FROM Hari:

Hi

If the Target is invalid, do not worry.
We do check if the Target exists in other accounts (Virginia) but we have no
way to find the correct location as the file no longer exists.

Details

Windows gives a Target as %userprofile%\desktop. Since we are running from
Fabio account, we expand it to Fabio's desktop.
But we also check if it exists in Virginia's desktop. If it does not exist
there, we show the original Target.

We will try to show the original Target, but it is not a serious bug if the
Target is invalid in the Virginia account.


RESPONSE FROM ME (FAM07):

Dear Hari
It is very clear your explanation. Thank you very much.
It is a minor issue. To have this issue solved would be a delicacy, but I
will apreciate your effort if it is possible to correct it.

Regards
FAM07

Post Reply